aboutsummaryrefslogtreecommitdiffstats
path: root/gentoo/cputemp2maxfreq-0.5.ebuild
diff options
context:
space:
mode:
authorPA4WDH2024-07-30 16:57:58 +0200
committerPA4WDH2024-07-30 16:57:58 +0200
commit0b4dcca473f0f7f58ba5958c3822dbd35129d1ba (patch)
treeee51ddcbd8d6684eb5aad2ae92192850a5c1379a /gentoo/cputemp2maxfreq-0.5.ebuild
parentUpdate README.html (diff)
downloadcputemp2maxfreq-0b4dcca473f0f7f58ba5958c3822dbd35129d1ba.tar.gz
cputemp2maxfreq-0b4dcca473f0f7f58ba5958c3822dbd35129d1ba.tar.bz2
cputemp2maxfreq-0b4dcca473f0f7f58ba5958c3822dbd35129d1ba.zip
Add ebuild for version 0.5
Diffstat (limited to 'gentoo/cputemp2maxfreq-0.5.ebuild')
-rw-r--r--gentoo/cputemp2maxfreq-0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gentoo/cputemp2maxfreq-0.5.ebuild b/gentoo/cputemp2maxfreq-0.5.ebuild
new file mode 100644
index 0000000..3650432
--- /dev/null
+++ b/gentoo/cputemp2maxfreq-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Daemon to scale scale_max_freq when CPU temperature rises"
+HOMEPAGE="https://code.pa4wdh.nl.eu.org/tools/cputemp2maxfreq/about"
+GIT_COMMIT="d669b9c4004a5aaeb026f399bcd3cb5ecfb69630"
+SRC_URI="https://code.pa4wdh.nl.eu.org/tools/cputemp2maxfreq/snapshot/cputemp2maxfreq-$GIT_COMMIT.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_unpack()
+{
+ unpack "${P}.tar.gz"
+ mv "cputemp2maxfreq-$GIT_COMMIT" "${P}"
+}
+
+src_prepare()
+{
+ eapply_user
+
+ ./generate_version_h.sh "${PV}" "${GIT_COMMIT:0:7}" "master" > version.h
+ mkdir .git
+ touch -d "1 minute ago" .git/index
+}
+
+src_install()
+{
+ dosbin ${PN}
+ newinitd "${FILESDIR}/cputemp2maxfreq.init" cputemp2maxfreq
+ newconfd "${FILESDIR}/cputemp2maxfreq.conf" cputemp2maxfreq
+}