aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPA4WDH2025-01-22 15:20:04 +0100
committerPA4WDH2025-01-22 15:20:04 +0100
commit194416796b27c46981ed5ff7fbc8b8a75ae23d74 (patch)
treebad2accd7ff85180a9f2b53e9e64177319540d16
parentAdd sys-apps/opentmpfiles-0.2-r1 (diff)
downloadopentmpfiles-194416796b27c46981ed5ff7fbc8b8a75ae23d74.tar.gz
opentmpfiles-194416796b27c46981ed5ff7fbc8b8a75ae23d74.tar.bz2
opentmpfiles-194416796b27c46981ed5ff7fbc8b8a75ae23d74.zip
Removed sys-apps/opentmpfiles-0.2 because EAPI 6 support is removed
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
deleted file mode 100644
index 021301a..0000000
--- a/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit prefix
-
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/openrc/${PN}"
-else
- SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
- ${P}.tar.gz
- https://code.pa4wdh.nl.eu.org/distfiles/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
-HOMEPAGE="https://github.com/openrc/opentmpfiles"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="selinux"
-
-RDEPEND="!<sys-apps/openrc-0.23
- selinux? ( sec-policy/selinux-base-policy )"
-
-src_prepare() {
- default
- hprefixify tmpfiles
-}
-src_install() {
- emake DESTDIR="${ED}" install
- einstalldocs
- cd openrc
- for f in opentmpfiles-dev opentmpfiles-setup; do
- newconfd ${f}.confd ${f}
- newinitd ${f}.initd ${f}
- done
-}
-
-add_service() {
- local initd=$1
- local runlevel=$2
-
- elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
- mkdir -p "${EROOT}"etc/runlevels/${runlevel}
- ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
-}
-
-pkg_postinst() {
- if [[ -z $REPLACING_VERSIONS ]]; then
- add_service opentmpfiles-dev sysinit
- add_service opentmpfiles-setup boot
- fi
-}