aboutsummaryrefslogtreecommitdiffstats
path: root/sys-apps
diff options
context:
space:
mode:
authorPA4WDH2021-08-04 14:06:14 +0200
committerPA4WDH2021-08-04 14:06:14 +0200
commitc8d646531324e81b8b5f03f5a9d0c4b7c798928e (patch)
treefc07031423aaa61714c7021e6485bf521d6bf990 /sys-apps
downloadopentmpfiles-c8d646531324e81b8b5f03f5a9d0c4b7c798928e.tar.gz
opentmpfiles-c8d646531324e81b8b5f03f5a9d0c4b7c798928e.tar.bz2
opentmpfiles-c8d646531324e81b8b5f03f5a9d0c4b7c798928e.zip
Initial commit
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/opentmpfiles/Manifest3
-rw-r--r--sys-apps/opentmpfiles/metadata.xml15
-rw-r--r--sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild55
3 files changed, 73 insertions, 0 deletions
diff --git a/sys-apps/opentmpfiles/Manifest b/sys-apps/opentmpfiles/Manifest
new file mode 100644
index 0000000..3147d0b
--- /dev/null
+++ b/sys-apps/opentmpfiles/Manifest
@@ -0,0 +1,3 @@
+DIST opentmpfiles-0.2.tar.gz 5711 BLAKE2B e1ee7820b2d184d18e63e7e9d93227bb301eb82be8c2b6021c7a1092f55a4ca2bb5dfb7494ff00c3b6debace1963f6c89011ff557f665f0a93c907bd759a4c6f SHA512 bc384cc9156ba6c54d3308ddad4d26b1877f020aa8558e82df2ed49ffa65e0fed5a49eaa11b27193bfe2ad11a4d7368f7cdbc225b820b309af3b299327ddb07b
+EBUILD opentmpfiles-0.2.ebuild 1437 BLAKE2B 3f79381bb031c46df9123a53313ea23471a145d08d48a821c373e8d232aa59c75131c2f42e8092a5a34fd21afd96e4608673121eb4e6611d8f35e476fa73c2bd SHA512 ce42fb5cbd88a53fb8093d8551470aefd50ddd61f6e5ebab40e7c7e43c870f83ba80c550d0ae48ba57e31e479d6f4761312f78433a4fe39359aa1e6c637d7a84
+MISC metadata.xml 445 BLAKE2B 4aad5dcfe48ca38a0de24e7c5a1fa53ec639827f9caa2f03c71fb2c054d74de487cda2eb7c8efccd20d5012955163bd9cef7f73f892a14e8ffd63bb73878dd90 SHA512 9dd3d1e30ceff27dbe6b5250ca0915d31957f94f830236b385d2cfcf2e28806d8fac23220148d7a7cfd09f73136e0bc728e1c289da77f939faff2c2d5c55dd6b
diff --git a/sys-apps/opentmpfiles/metadata.xml b/sys-apps/opentmpfiles/metadata.xml
new file mode 100644
index 0000000..e38bd1f
--- /dev/null
+++ b/sys-apps/opentmpfiles/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openrc@gentoo.org</email>
+ <name>Gentoo OpenRC Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openrc/opentmpfiles</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
new file mode 100644
index 0000000..021301a
--- /dev/null
+++ b/sys-apps/opentmpfiles/opentmpfiles-0.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit prefix
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openrc/${PN}"
+else
+ SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
+ ${P}.tar.gz
+ https://code.pa4wdh.nl.eu.org/distfiles/${P}.tar.gz"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
+HOMEPAGE="https://github.com/openrc/opentmpfiles"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="selinux"
+
+RDEPEND="!<sys-apps/openrc-0.23
+ selinux? ( sec-policy/selinux-base-policy )"
+
+src_prepare() {
+ default
+ hprefixify tmpfiles
+}
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+ cd openrc
+ for f in opentmpfiles-dev opentmpfiles-setup; do
+ newconfd ${f}.confd ${f}
+ newinitd ${f}.initd ${f}
+ done
+}
+
+add_service() {
+ local initd=$1
+ local runlevel=$2
+
+ elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+ mkdir -p "${EROOT}"etc/runlevels/${runlevel}
+ ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
+}
+
+pkg_postinst() {
+ if [[ -z $REPLACING_VERSIONS ]]; then
+ add_service opentmpfiles-dev sysinit
+ add_service opentmpfiles-setup boot
+ fi
+}