aboutsummaryrefslogtreecommitdiffstats
path: root/sys-boot/opensbi/opensbi-1.0.ebuild
diff options
context:
space:
mode:
authorPA4WDH2022-07-30 14:27:40 +0200
committerPA4WDH2022-07-30 14:27:40 +0200
commitcce6c03083cdb1e836f32e2bb2a8f66d7428af4d (patch)
tree0ce74b72c92be01b69d22751367e767561413744 /sys-boot/opensbi/opensbi-1.0.ebuild
parentAdd sys-kernel/sifive-sources-5.18.8 (diff)
downloadunmatched-patchwork-cce6c03083cdb1e836f32e2bb2a8f66d7428af4d.tar.gz
unmatched-patchwork-cce6c03083cdb1e836f32e2bb2a8f66d7428af4d.tar.bz2
unmatched-patchwork-cce6c03083cdb1e836f32e2bb2a8f66d7428af4d.zip
Add sys-boot/opensbi-1.0 and sys-boot/u-boot-2022.06
Diffstat (limited to 'sys-boot/opensbi/opensbi-1.0.ebuild')
-rw-r--r--sys-boot/opensbi/opensbi-1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-boot/opensbi/opensbi-1.0.ebuild b/sys-boot/opensbi/opensbi-1.0.ebuild
new file mode 100644
index 0000000..ec120e2
--- /dev/null
+++ b/sys-boot/opensbi/opensbi-1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+OPENSBI_COMMIT="fab0379bb60d6e177018b53f07718b69ba34948d"
+
+DESCRIPTION="RISC-V Supervisor Binary Interface (SBI)"
+HOMEPAGE="https://github.com/riscv/${PN}/tree/v${PV}"
+SRC_URI="https://github.com/riscv-software-src/${PN}/archive/${OPENSBI_COMMIT}.zip -> ${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~riscv"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_unpack() {
+ unpack ${P}.zip
+ mv "${WORKDIR}/opensbi-${OPENSBI_COMMIT}" "${WORKDIR}/${P}"
+}
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ emake PLATFORM=generic FW_PIC=n
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${P}"
+ cp "${WORKDIR}/${P}/build/platform/generic/firmware/fw_dynamic.bin" "${D}/usr/share/${P}"
+ elog "Installed OpenSBI at /usr/share/${P}/fw_dynamic.bin"
+ dodoc CONTRIBUTORS.md
+ dodoc COPYING.BSD
+ dodoc README.md
+ dodoc ThirdPartyNotices.md
+}