aboutsummaryrefslogtreecommitdiffstats
path: root/sys-boot/opensbi/opensbi-1.4.ebuild
diff options
context:
space:
mode:
authorPA4WDH2024-07-06 11:15:10 +0200
committerPA4WDH2024-07-06 11:15:10 +0200
commit25dee51c26924e4c6d8e6e0467b942d51e2a5f84 (patch)
tree503860c1d1b8b4db57ef3d3c9ed0046ea7b59a95 /sys-boot/opensbi/opensbi-1.4.ebuild
parentAdd sys-apps/sysvinit-3.08 (diff)
downloadunmatched-patchwork-25dee51c26924e4c6d8e6e0467b942d51e2a5f84.tar.gz
unmatched-patchwork-25dee51c26924e4c6d8e6e0467b942d51e2a5f84.tar.bz2
unmatched-patchwork-25dee51c26924e4c6d8e6e0467b942d51e2a5f84.zip
Add sys-boot/opensbi-1.4 and sys-boot/u-boot-2024.01HEADmaster
Diffstat (limited to 'sys-boot/opensbi/opensbi-1.4.ebuild')
-rw-r--r--sys-boot/opensbi/opensbi-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-boot/opensbi/opensbi-1.4.ebuild b/sys-boot/opensbi/opensbi-1.4.ebuild
new file mode 100644
index 0000000..12037ba
--- /dev/null
+++ b/sys-boot/opensbi/opensbi-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+OPENSBI_COMMIT="a2b255b88918715173942f2c5e1f97ac9e90c877"
+
+DESCRIPTION="RISC-V Supervisor Binary Interface (SBI)"
+HOMEPAGE="https://github.com/riscv/${PN}/tree/v${PV}"
+SRC_URI="https://github.com/riscv-software-src/${PN}/archive/${OPENSBI_COMMIT}.zip -> ${P}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~riscv"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_unpack() {
+ unpack ${P}.zip
+ mv "${WORKDIR}/opensbi-${OPENSBI_COMMIT}" "${WORKDIR}/${P}"
+}
+
+src_prepare() {
+ default
+}
+
+src_compile() {
+ emake PLATFORM=generic FW_PIC=y
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${P}"
+ cp "${WORKDIR}/${P}/build/platform/generic/firmware/fw_dynamic.bin" "${D}/usr/share/${P}"
+ elog "Installed OpenSBI at /usr/share/${P}/fw_dynamic.bin"
+ dodoc CONTRIBUTORS.md
+ dodoc COPYING.BSD
+ dodoc README.md
+ dodoc ThirdPartyNotices.md
+}