aboutsummaryrefslogtreecommitdiffstats
path: root/sys-boot/opensbi
diff options
context:
space:
mode:
authorPA4WDH2021-07-13 19:47:04 +0200
committerPA4WDH2021-07-13 19:47:04 +0200
commit5884c94b1f92c00406d137c9f308c098e5268a59 (patch)
tree8483f1da04bf5cbed41220bafcffa502cae95eaa /sys-boot/opensbi
downloadunmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.tar.gz
unmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.tar.bz2
unmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.zip
Initial commit
Diffstat (limited to 'sys-boot/opensbi')
-rw-r--r--sys-boot/opensbi/Manifest3
-rw-r--r--sys-boot/opensbi/opensbi-0.9.ebuild39
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-boot/opensbi/Manifest b/sys-boot/opensbi/Manifest
new file mode 100644
index 0000000..3ea0225
--- /dev/null
+++ b/sys-boot/opensbi/Manifest
@@ -0,0 +1,3 @@
+DIST meta-sifive-2021.05.zip 664346 BLAKE2B ca98d75c4fc255f3ec99c3e9667e1a5e43fc1db88b83010db3766ff8e70acfaf2741dde96da65265aeef5ca82e1cc93a96ea771dd48cc2c9ff4af24d3feb4b82 SHA512 e60052fc183ddd89a4b0a2a443aedfe22c20ce1134925d6c0d52946ce9a5ca04750408fcb7b191ecc30b4d4b21c9e2f262d0d2b89527923a7cd82dc01a7f2345
+DIST opensbi-0.9.zip 290818 BLAKE2B 5a8903c118faea18fc8e6b023ca0b1a393da2deb57f8b2d685c0547d9dadb1ebf7dc60e442a8976f10809e3ef54d03dfd81c853bc75991f193427cc28c68b360 SHA512 2caf042db0437207f33791d6e2a250311b2c805c0da79bfbb6cbec193e24c2ba26a69ef9c4f56d0c3d4a7a66cf2c656c8e453a8da0f492382464145b231cc690
+EBUILD opensbi-0.9.ebuild 1078 BLAKE2B e0c862d73eeeac60869c95acdc3a8138a4b0169d90fa2a38d65fdf53bf132e306defa4971f004132e093136bc8a1c4e2a5407cfd2f20ef312f1fe9323c6e1397 SHA512 2d1c2ecb7a663ff637eab3f383d3c046834ebd7018d85bde7a7efe4a0bb47965f140488de4cbd39911dac8029c941410f1baa5384d81349f6f84a2d4b16c8fba
diff --git a/sys-boot/opensbi/opensbi-0.9.ebuild b/sys-boot/opensbi/opensbi-0.9.ebuild
new file mode 100644
index 0000000..746e0b3
--- /dev/null
+++ b/sys-boot/opensbi/opensbi-0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+META_SIFIVE="2021.05"
+
+DESCRIPTION="RISC-V Supervisor Binary Interface (SBI) with meta-sifive-${META_SIFIVE} patches"
+HOMEPAGE="https://github.com/riscv/${PN}/tree/v${PV}"
+SRC_URI="https://github.com/riscv/${PN}/archive/refs/tags/v${PV}.zip -> ${P}.zip
+ https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~riscv"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ eapply "${WORKDIR}/meta-sifive-${META_SIFIVE}/recipes-bsp/opensbi/files"
+ eapply "${WORKDIR}/meta-sifive-${META_SIFIVE}/recipes-bsp/opensbi/files/unmatched"
+ default
+}
+
+src_compile() {
+ emake PLATFORM=generic
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${P}"
+ cp "${WORKDIR}/${P}/build/platform/generic/firmware/fw_dynamic.bin" "${D}/usr/share/${P}"
+ elog "Installed OpenSBI at /usr/share/${P}/fw_dynamic.bin"
+ dodoc CONTRIBUTORS.md
+ dodoc COPYING.BSD
+ dodoc README.md
+ dodoc ThirdPartyNotices.md
+}