aboutsummaryrefslogtreecommitdiffstats
path: root/sys-boot/u-boot/u-boot-2021.07.ebuild
diff options
context:
space:
mode:
authorPA4WDH2021-07-31 19:20:21 +0200
committerPA4WDH2021-07-31 19:20:21 +0200
commit1aa02c385df1903e8781d692e24e14ef1e082bfa (patch)
tree10f21108b4123f74a3301f2f89c5e74c65fa0e8d /sys-boot/u-boot/u-boot-2021.07.ebuild
parentAdd sys-boot/u-boot-2021.07 (diff)
downloadunmatched-patchwork-1aa02c385df1903e8781d692e24e14ef1e082bfa.tar.gz
unmatched-patchwork-1aa02c385df1903e8781d692e24e14ef1e082bfa.tar.bz2
unmatched-patchwork-1aa02c385df1903e8781d692e24e14ef1e082bfa.zip
Add patch to sys-boot/u-boot-2021.07 to make it work
Diffstat (limited to 'sys-boot/u-boot/u-boot-2021.07.ebuild')
-rw-r--r--sys-boot/u-boot/u-boot-2021.07.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-boot/u-boot/u-boot-2021.07.ebuild b/sys-boot/u-boot/u-boot-2021.07.ebuild
index fe97196..e7d5d41 100644
--- a/sys-boot/u-boot/u-boot-2021.07.ebuild
+++ b/sys-boot/u-boot/u-boot-2021.07.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://source.denx.de/u-boot/u-boot/-/archive/${UBOOT_COMMIT}/u-boot-$
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~riscv"
DEPEND="sys-boot/opensbi sys-apps/dtc dev-lang/swig"
RDEPEND="${DEPEND}"
@@ -44,7 +44,7 @@ src_prepare() {
use 1600 && CONFIG_SPEED=1600000000
use 1700 && CONFIG_SPEED=1700000000
- # Actaually modify the dtsi file
+ # Actually modify the dtsi file
sed -i -E -e "/cpus/,/cpu0/ s/assigned-clock-rates = <[0-9]+>/assigned-clock-rates = <${CONFIG_SPEED}>/" "${WORKDIR}/${P}/arch/riscv/dts/fu740-c000-u-boot.dtsi"
elog "Set CPU frquency to $((CONFIG_SPEED/1000000)) Mhz"
@@ -52,6 +52,8 @@ src_prepare() {
eapply "${FILESDIR}/efi-priority.patch"
fi
+ eapply "${FILESDIR}/sifive-unmached-fdt-initrd-env.patch"
+
eapply_user
}
@@ -86,6 +88,4 @@ pkg_postinst()
einfo "dd. For example:"
einfo "dd if=/usr/share/${P}/u-boot-spl.bin of=<partition with type \"HiFive Unleashed FSBL\">"
einfo "dd if=/usr/share/${P}/u-boot.itb of=<partition with type \"HiFive Unleashed BBL\">"
- einfo ""
- ewarn "This version does not boot correctly, it is not keyworded for a reason :-)"
}