aboutsummaryrefslogtreecommitdiffstats
path: root/sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild
diff options
context:
space:
mode:
authorPA4WDH2021-12-04 17:05:14 +0100
committerPA4WDH2021-12-04 17:05:14 +0100
commitbc94654fe6fc4bd431facfc68afc000b67d49038 (patch)
tree673f7e1ad43367b61c4e14227d44955702f1596f /sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild
parentAdd sys-boot/u-boot-2021.10 (diff)
downloadunmatched-patchwork-bc94654fe6fc4bd431facfc68afc000b67d49038.tar.gz
unmatched-patchwork-bc94654fe6fc4bd431facfc68afc000b67d49038.tar.bz2
unmatched-patchwork-bc94654fe6fc4bd431facfc68afc000b67d49038.zip
Add sys-kernel/sifive-sources-5.13.19 and sys-kernel/sifive-sources-5.14.15
Diffstat (limited to 'sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild')
-rw-r--r--sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild b/sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild
new file mode 100644
index 0000000..e254126
--- /dev/null
+++ b/sys-kernel/sifive-sources/sifive-sources-5.14.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="16"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/sifive/meta-sifive"
+IUSE="experimental"
+
+META_SIFIVE="2021.11"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and meta-sifive-${META_SIFIVE} patches"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+src_prepare() {
+ unpack meta-sifive-${META_SIFIVE}.zip
+ eapply "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files"
+ cp "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files/defconfig" "${WORKDIR}/linux-${KV_FULL}/arch/riscv/configs/unmatched_defconfig"
+ rm -R "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}"
+ eapply_user
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}