aboutsummaryrefslogtreecommitdiffstats
path: root/sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild
diff options
context:
space:
mode:
authorPA4WDH2021-09-19 15:00:18 +0200
committerPA4WDH2021-09-19 15:00:18 +0200
commit3f64643d29fda8a292018c39f5e7358f994930c6 (patch)
tree9d17ff8783a62783da83d3d90d4b0faf23667d65 /sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild
parentAdd sys-boot/grub-2.06-r1 (diff)
downloadunmatched-patchwork-3f64643d29fda8a292018c39f5e7358f994930c6.tar.gz
unmatched-patchwork-3f64643d29fda8a292018c39f5e7358f994930c6.tar.bz2
unmatched-patchwork-3f64643d29fda8a292018c39f5e7358f994930c6.zip
Add sifive-sources-5.13.9 and sifive-sources-5.14.3
Diffstat (limited to 'sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild')
-rw-r--r--sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild b/sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild
new file mode 100644
index 0000000..e749a09
--- /dev/null
+++ b/sys-kernel/sifive-sources/sifive-sources-5.14.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="4"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/sifive/meta-sifive"
+IUSE="experimental"
+
+META_SIFIVE="2021.08"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and meta-sifive-${META_SIFIVE} patches"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+
+src_prepare() {
+ unpack meta-sifive-${META_SIFIVE}.zip
+ local SIFIVE_PATCH
+ local SIFIVE_PATCHES="
+ 0001-riscv-sifive-fu740-cpu-1-2-3-4-set-compatible-to-sif.patch
+ 0003-riscv-sifive-unmatched-add-D12-PWM-LED.patch
+ 0004-riscv-sifive-unmatched-add-gpio-poweroff-node.patch
+ 0005-riscv-sifive-unmatched-add-D2-RGB-LED.patch
+ 0006-riscv-sifive-unmatched-remove-A00-from-model.patch
+ 0007-riscv-sifive-unmatched-define-LEDs-color.patch
+ 0009-SiFive-HiFive-Unleashed-Add-PWM-LEDs-D1-D2-D3-D4.patch
+ 0010-riscv-sifive-unleashed-define-opp-table-cpufreq.patch
+ "
+
+ local SIFIVE_PATH="${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files"
+ for SIFIVE_PATCH in $SIFIVE_PATCHES
+ do
+ eapply "${SIFIVE_PATH}/${SIFIVE_PATCH}"
+ done
+
+ cp "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files/defconfig" "${WORKDIR}/linux-${KV_FULL}/arch/riscv/configs/unmatched_defconfig"
+ rm -R "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}"
+ eapply_user
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}