aboutsummaryrefslogtreecommitdiffstats
path: root/sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild
diff options
context:
space:
mode:
authorPA4WDH2022-02-19 13:06:53 +0100
committerPA4WDH2022-02-19 13:06:53 +0100
commite12bd89f997ac5914e4fd51d158254a9b0831950 (patch)
treee032636956728f0146e3516e96d24249f0f52154 /sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild
parentAdd sys-boot/opensbi-0.9_p3 (diff)
downloadunmatched-patchwork-e12bd89f997ac5914e4fd51d158254a9b0831950.tar.gz
unmatched-patchwork-e12bd89f997ac5914e4fd51d158254a9b0831950.tar.bz2
unmatched-patchwork-e12bd89f997ac5914e4fd51d158254a9b0831950.zip
Add sys-kernel/sifive-sources-5.15.24
Diffstat (limited to 'sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild')
-rw-r--r--sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild b/sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild
new file mode 100644
index 0000000..98bc624
--- /dev/null
+++ b/sys-kernel/sifive-sources/sifive-sources-5.15.24.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="26"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/sifive/meta-sifive"
+IUSE="experimental"
+
+META_SIFIVE="2021.11"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and meta-sifive-${META_SIFIVE} patches"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+src_prepare() {
+ unpack meta-sifive-${META_SIFIVE}.zip
+ rm "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files/0004-riscv-sifive-unmatched-add-gpio-poweroff-node.patch"
+ rm "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files/29868ae1478fe18231672da94c4e862a03218a25.patch"
+ eapply "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files"
+ cp "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/files/defconfig" "${WORKDIR}/linux-${KV_FULL}/arch/riscv/configs/unmatched_defconfig"
+ rm -R "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}"
+ eapply_user
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}