aboutsummaryrefslogtreecommitdiffstats
path: root/sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild')
-rw-r--r--sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild b/sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild
new file mode 100644
index 0000000..aec59c8
--- /dev/null
+++ b/sys-kernel/sifive-sources/sifive-sources-6.6.21.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="27"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+META_SIFIVE="2024.03"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree and meta-sifive-${META_SIFIVE} patches"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+src_prepare() {
+ unpack meta-sifive-${META_SIFIVE}.zip
+ cp "${WORKDIR}/linux-${KV_FULL}/meta-sifive-${META_SIFIVE}/recipes-kernel/linux/linux-sifive-6.6.21+git/unmatched/defconfig" "${WORKDIR}/linux-${KV_FULL}/arch/riscv/configs/unmatched_defconfig"
+ eapply_user
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}