aboutsummaryrefslogtreecommitdiffstats
path: root/gentoo/cputemp2maxfreq-0.3.ebuild
diff options
context:
space:
mode:
authorPA4WDH2023-05-27 11:52:20 +0200
committerPA4WDH2023-05-27 11:52:20 +0200
commitca433075bfec59ebc18c13af2282d11dc8cd132c (patch)
tree336d51f9821fda51238cbc69ceb87745bd382188 /gentoo/cputemp2maxfreq-0.3.ebuild
parentUpdate README.html (diff)
downloadcputemp2maxfreq-ca433075bfec59ebc18c13af2282d11dc8cd132c.tar.gz
cputemp2maxfreq-ca433075bfec59ebc18c13af2282d11dc8cd132c.tar.bz2
cputemp2maxfreq-ca433075bfec59ebc18c13af2282d11dc8cd132c.zip
Add ebuild for version 0.3
Diffstat (limited to 'gentoo/cputemp2maxfreq-0.3.ebuild')
-rw-r--r--gentoo/cputemp2maxfreq-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gentoo/cputemp2maxfreq-0.3.ebuild b/gentoo/cputemp2maxfreq-0.3.ebuild
new file mode 100644
index 0000000..8f34b1f
--- /dev/null
+++ b/gentoo/cputemp2maxfreq-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Daemon to scale scale_max_freq when CPU temperature rises"
+HOMEPAGE="https://code.pa4wdh.nl.eu.org/tools/cputemp2maxfreq/about"
+GIT_COMMIT="beed43a886451373b3cbfb8bb2a946e74fe16d05"
+SRC_URI="https://code.pa4wdh.nl.eu.org/tools/cputemp2maxfreq/snapshot/cputemp2maxfreq-$GIT_COMMIT.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_unpack()
+{
+ unpack "${P}.tar.gz"
+ mv "cputemp2maxfreq-$GIT_COMMIT" "${P}"
+}
+
+src_prepare()
+{
+ eapply_user
+
+ ./generate_version_h.sh "${PV}" "${GIT_COMMIT:0:7}" "master" > version.h
+ mkdir .git
+ touch -d "1 minute ago" .git/index
+}
+
+src_install()
+{
+ dosbin ${PN}
+ newinitd "${FILESDIR}/cputemp2maxfreq.init" cputemp2maxfreq
+ newconfd "${FILESDIR}/cputemp2maxfreq.conf" cputemp2maxfreq
+}