aboutsummaryrefslogtreecommitdiffstats
path: root/sys-boot/opensbi/opensbi-0.9.ebuild
diff options
context:
space:
mode:
authorPA4WDH2021-07-13 19:47:04 +0200
committerPA4WDH2021-07-13 19:47:04 +0200
commit5884c94b1f92c00406d137c9f308c098e5268a59 (patch)
tree8483f1da04bf5cbed41220bafcffa502cae95eaa /sys-boot/opensbi/opensbi-0.9.ebuild
downloadunmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.tar.gz
unmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.tar.bz2
unmatched-patchwork-5884c94b1f92c00406d137c9f308c098e5268a59.zip
Initial commit
Diffstat (limited to 'sys-boot/opensbi/opensbi-0.9.ebuild')
-rw-r--r--sys-boot/opensbi/opensbi-0.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-boot/opensbi/opensbi-0.9.ebuild b/sys-boot/opensbi/opensbi-0.9.ebuild
new file mode 100644
index 0000000..746e0b3
--- /dev/null
+++ b/sys-boot/opensbi/opensbi-0.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+META_SIFIVE="2021.05"
+
+DESCRIPTION="RISC-V Supervisor Binary Interface (SBI) with meta-sifive-${META_SIFIVE} patches"
+HOMEPAGE="https://github.com/riscv/${PN}/tree/v${PV}"
+SRC_URI="https://github.com/riscv/${PN}/archive/refs/tags/v${PV}.zip -> ${P}.zip
+ https://github.com/sifive/meta-sifive/archive/refs/heads/${META_SIFIVE}.zip -> meta-sifive-${META_SIFIVE}.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~riscv"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ eapply "${WORKDIR}/meta-sifive-${META_SIFIVE}/recipes-bsp/opensbi/files"
+ eapply "${WORKDIR}/meta-sifive-${META_SIFIVE}/recipes-bsp/opensbi/files/unmatched"
+ default
+}
+
+src_compile() {
+ emake PLATFORM=generic
+}
+
+src_install() {
+ mkdir -p "${D}/usr/share/${P}"
+ cp "${WORKDIR}/${P}/build/platform/generic/firmware/fw_dynamic.bin" "${D}/usr/share/${P}"
+ elog "Installed OpenSBI at /usr/share/${P}/fw_dynamic.bin"
+ dodoc CONTRIBUTORS.md
+ dodoc COPYING.BSD
+ dodoc README.md
+ dodoc ThirdPartyNotices.md
+}